$re = '/^(.*?)(?:\s*((?:[a-zA-Z]+[0-9]|[0-9]+[a-zA-Z]).*))?$/m';
$str = 'WASHER tey DIN6340 10.5 C 35;
CABINET EL
CYLINDER SCREW
M12x N15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);