const regex = new RegExp('^(.*?)(?:\\s*((?:[a-zA-Z]+[0-9]|[0-9]+[a-zA-Z]).*))?$', 'gm')
const str = `WASHER tey DIN6340 10.5 C 35;
CABINET EL
CYLINDER SCREW
M12x N15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}