using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<type>@param) *\K(?<scalar>(?![\$])\S+)? *\K(?<var>\$\S+) *\K(?<message>\S+.*\S+)";
string input = @"--- Copyright @fmargerit ---
/**
* First variation with scalar type
*
* @param Int $a First parameter to add
* @param Int $b Second parameter to add
*
*/
/**
* second variation without scalar type
*
* @param $a first text
* @param $b second text
* @param $c third text
*
*/
/**
* Invalid case without message
*
* @param Int $a
*
*/
/**
* Invalid case : without variable
*
* @param Int coucou
*
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}