import Foundation
let pattern = #"(?m)(?<type>@param) *\K(?<scalar>(?![\$])\S+)? *\K(?<var>\$\S+) *\K(?<message>\S+.*\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
--- Copyright @fmargerit ---
/**
* First variation with scalar type
*
* @param Int $a First parameter to add
* @param Int $b Second parameter to add
*
*/
/**
* second variation without scalar type
*
* @param $a first text
* @param $b second text
* @param $c third text
*
*/
/**
* Invalid case without message
*
* @param Int $a
*
*/
/**
* Invalid case : without variable
*
* @param Int coucou
*
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)