use strict;
my $str = '--- Copyright @fmargerit ---
/**
* First variation with scalar type
*
* @param Int $a First parameter to add
* @param Int $b Second parameter to add
*
*/
/**
* second variation without scalar type
*
* @param $a first text
* @param $b second text
* @param $c third text
*
*/
/**
* Invalid case without message
*
* @param Int $a
*
*/
/**
* Invalid case : without variable
*
* @param Int coucou
*
*/';
my $regex = qr/(?m)(?<type>@param) *\K(?<scalar>(?![\$])\S+)? *\K(?<var>\$\S+) *\K(?<message>\S+.*\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}