re = /(?m)(?<type>@param) *\K(?<scalar>(?![\$])\S+)? *\K(?<var>\$\S+) *\K(?<message>\S+.*\S+)/m
str = '--- Copyright @fmargerit ---
/**
* First variation with scalar type
*
* @param Int $a First parameter to add
* @param Int $b Second parameter to add
*
*/
/**
* second variation without scalar type
*
* @param $a first text
* @param $b second text
* @param $c third text
*
*/
/**
* Invalid case without message
*
* @param Int $a
*
*/
/**
* Invalid case : without variable
*
* @param Int coucou
*
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end