import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<position>top|left)\\s*\\:\\s*(?P<value>[\\d]+(?:\\.[\\d]+)?)(?P<measure>px|%|em|pt);?";
final String string = "position: absolute; cursor: pointer; width: 20px; height: 20px; left: 995.503px; top: 297.366px;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}