$re = '/(?P<position>top|left)\s*\:\s*(?P<value>[\d]+(?:\.[\d]+)?)(?P<measure>px|%|em|pt);?/';
$str = 'position: absolute; cursor: pointer; width: 20px; height: 20px; left: 995.503px; top: 297.366px;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);