using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(.+)";
string input = @"http://www.olafpleines.de/?dies-das-jenes
http://www.olafpleines.de/#viel?holter-die-polter
http://www.olafpleines.de/wer?wimmelbilderwimmellei
http://www.olafpleines.de/wer?wimmelbilderwimmellei#542254257
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}