$re = '/#(.+)/m';
$str = 'http://www.olafpleines.de/?dies-das-jenes
http://www.olafpleines.de/#viel?holter-die-polter
http://www.olafpleines.de/wer?wimmelbilderwimmellei
http://www.olafpleines.de/wer?wimmelbilderwimmellei#542254257
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);