import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(.+)";
final String string = "http://www.olafpleines.de/?dies-das-jenes\n"
+ "http://www.olafpleines.de/#viel?holter-die-polter\n"
+ "http://www.olafpleines.de/wer?wimmelbilderwimmellei\n"
+ "http://www.olafpleines.de/wer?wimmelbilderwimmellei#542254257\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}