package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#(.+)`)
var str = `http://www.olafpleines.de/?dies-das-jenes
http://www.olafpleines.de/#viel?holter-die-polter
http://www.olafpleines.de/wer?wimmelbilderwimmellei
http://www.olafpleines.de/wer?wimmelbilderwimmellei#542254257
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}