re = /#(.+)/m
str = 'http://www.olafpleines.de/?dies-das-jenes
http://www.olafpleines.de/#viel?holter-die-polter
http://www.olafpleines.de/wer?wimmelbilderwimmellei
http://www.olafpleines.de/wer?wimmelbilderwimmellei#542254257
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end