using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([exibebanner [^])(]*)id=[""'][^""']+";
string input = @"[exibebanner id=""300""] <br/>é simplesmente uma simulação de texto da indústria tipográfica <br/><b>[exibebanner id=""40""]</b> e de impressos, e vem sendo utilizado desde o século XVI, quando um impressor desconhecido pegou um<br/> <b>[exibebanner id=""90""]</b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}