package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([exibebanner [^])(]*)id=["'][^"']+`)
var str = `[exibebanner id="300"] <br/>é simplesmente uma simulação de texto da indústria tipográfica <br/><b>[exibebanner id="40"]</b> e de impressos, e vem sendo utilizado desde o século XVI, quando um impressor desconhecido pegou um<br/> <b>[exibebanner id="90"]</b>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}