// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([exibebanner [^])(]*)id=["'][^"']+"#).unwrap();
let string = "[exibebanner id=\"300\"] <br/>é simplesmente uma simulação de texto da indústria tipográfica <br/><b>[exibebanner id=\"40\"]</b> e de impressos, e vem sendo utilizado desde o século XVI, quando um impressor desconhecido pegou um<br/> <b>[exibebanner id=\"90\"]</b>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}