re = /([exibebanner [^])(]*)id=["'][^"']+/m
str = '[exibebanner id="300"] <br/>é simplesmente uma simulação de texto da indústria tipográfica <br/><b>[exibebanner id="40"]</b> e de impressos, e vem sendo utilizado desde o século XVI, quando um impressor desconhecido pegou um<br/> <b>[exibebanner id="90"]</b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end