import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(blue)(.*?)(grey(?!\\ -\\ ))";
final String string = "test test test\n"
+ "blue\n"
+ "test test test\n"
+ "red 23\n"
+ "test test test\n"
+ "grey\n"
+ "test test test\n"
+ "blue\n"
+ "test test test\n"
+ "red 99\n"
+ "test test test\n"
+ "grey - blue\n"
+ "test test test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}