const regex = /(?s)(blue)(.*?)(grey(?!\ -\ ))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(blue)(.*?)(grey(?!\\ -\\ ))', 'gm')
const str = `test test test
blue
test test test
red 23
test test test
grey
test test test
blue
test test test
red 99
test test test
grey - blue
test test test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}