re = /(?s)(blue)(.*?)(grey(?!\ -\ ))/m
str = 'test test test
blue
test test test
red 23
test test test
grey
test test test
blue
test test test
red 99
test test test
grey - blue
test test test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end