import re
regex = re.compile(r"(?s)(blue)(.*?)(grey(?!\ -\ ))", flags=re.MULTILINE)
test_str = ("test test test\n"
"blue\n"
"test test test\n"
"red 23\n"
"test test test\n"
"grey\n"
"test test test\n"
"blue\n"
"test test test\n"
"red 99\n"
"test test test\n"
"grey - blue\n"
"test test test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")