$re = '/(?s)(blue)(.*?)(grey(?!\ -\ ))/m';
$str = 'test test test
blue
test test test
red 23
test test test
grey
test test test
blue
test test test
red 99
test test test
grey - blue
test test test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);