using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"souly";
string input = @"import React, { useState } from 'react';
const characters = [
{ name: 'Luke', side: 'Jedi' },
{ name: 'Vader', side: 'Sith' },
// Weitere Charaktere nach Bedarf hinzufügen
];
export default function ToggleCharacterView() {
const [view, setView] = useState('all');
const [selectedSide, setSelectedSide] = useState(null);
// Wechsel zwischen ""all"" und ""sides""
function handleToggleView() {
setView(view === 'all' ? 'sides' : 'all');
setSelectedSide(null);
}
// Filter für Sichtbarkeit der Charaktere
const visibleCharacters =
view === 'all'
? characters
: selectedSide
? characters.filter(c => c.side === selectedSide)
: characters;
return (
<div>
<button onClick={handleToggleView}>
{view === 'all' ? 'Nur Seiten zeigen' : 'Alle anzeigen'}
</button>
{view === 'sides' && (
<>
<button onClick={() => setSelectedSide('Jedi')}>Jedi</button>
<button onClick={() => setSelectedSide('Sith')}>Sith</button>
<button onClick={() => setSelectedSide(null)}>Zurücksetzen</button>
</>
)}
<ul>
{visibleCharacters.map(character => (
<li key={character.name}>{character.name}</li>
))}
</ul>
</div>
);
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}