use strict;
my $str = 'import React, { useState } from \'react\';
const characters = [
{ name: \'Luke\', side: \'Jedi\' },
{ name: \'Vader\', side: \'Sith\' },
// Weitere Charaktere nach Bedarf hinzufügen
];
export default function ToggleCharacterView() {
const [view, setView] = useState(\'all\');
const [selectedSide, setSelectedSide] = useState(null);
// Wechsel zwischen "all" und "sides"
function handleToggleView() {
setView(view === \'all\' ? \'sides\' : \'all\');
setSelectedSide(null);
}
// Filter für Sichtbarkeit der Charaktere
const visibleCharacters =
view === \'all\'
? characters
: selectedSide
? characters.filter(c => c.side === selectedSide)
: characters;
return (
<div>
<button onClick={handleToggleView}>
{view === \'all\' ? \'Nur Seiten zeigen\' : \'Alle anzeigen\'}
</button>
{view === \'sides\' && (
<>
<button onClick={() => setSelectedSide(\'Jedi\')}>Jedi</button>
<button onClick={() => setSelectedSide(\'Sith\')}>Sith</button>
<button onClick={() => setSelectedSide(null)}>Zurücksetzen</button>
</>
)}
<ul>
{visibleCharacters.map(character => (
<li key={character.name}>{character.name}</li>
))}
</ul>
</div>
);
}
';
my $regex = qr/souly/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}