package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)souly`)
var str = `import React, { useState } from 'react';
const characters = [
{ name: 'Luke', side: 'Jedi' },
{ name: 'Vader', side: 'Sith' },
// Weitere Charaktere nach Bedarf hinzufügen
];
export default function ToggleCharacterView() {
const [view, setView] = useState('all');
const [selectedSide, setSelectedSide] = useState(null);
// Wechsel zwischen "all" und "sides"
function handleToggleView() {
setView(view === 'all' ? 'sides' : 'all');
setSelectedSide(null);
}
// Filter für Sichtbarkeit der Charaktere
const visibleCharacters =
view === 'all'
? characters
: selectedSide
? characters.filter(c => c.side === selectedSide)
: characters;
return (
<div>
<button onClick={handleToggleView}>
{view === 'all' ? 'Nur Seiten zeigen' : 'Alle anzeigen'}
</button>
{view === 'sides' && (
<>
<button onClick={() => setSelectedSide('Jedi')}>Jedi</button>
<button onClick={() => setSelectedSide('Sith')}>Sith</button>
<button onClick={() => setSelectedSide(null)}>Zurücksetzen</button>
</>
)}
<ul>
{visibleCharacters.map(character => (
<li key={character.name}>{character.name}</li>
))}
</ul>
</div>
);
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}