# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"souly"
test_str = ("import React, { useState } from 'react';\n\n"
"const characters = [\n"
" { name: 'Luke', side: 'Jedi' },\n"
" { name: 'Vader', side: 'Sith' },\n"
" // Weitere Charaktere nach Bedarf hinzufügen\n"
"];\n\n"
"export default function ToggleCharacterView() {\n"
" const [view, setView] = useState('all');\n"
" const [selectedSide, setSelectedSide] = useState(null);\n\n"
" // Wechsel zwischen \"all\" und \"sides\"\n"
" function handleToggleView() {\n"
" setView(view === 'all' ? 'sides' : 'all');\n"
" setSelectedSide(null);\n"
" }\n\n"
" // Filter für Sichtbarkeit der Charaktere\n"
" const visibleCharacters =\n"
" view === 'all'\n"
" ? characters\n"
" : selectedSide\n"
" ? characters.filter(c => c.side === selectedSide)\n"
" : characters;\n\n"
" return (\n"
" <div>\n"
" <button onClick={handleToggleView}>\n"
" {view === 'all' ? 'Nur Seiten zeigen' : 'Alle anzeigen'}\n"
" </button>\n"
" {view === 'sides' && (\n"
" <>\n"
" <button onClick={() => setSelectedSide('Jedi')}>Jedi</button>\n"
" <button onClick={() => setSelectedSide('Sith')}>Sith</button>\n"
" <button onClick={() => setSelectedSide(null)}>Zurücksetzen</button>\n"
" </>\n"
" )}\n"
" <ul>\n"
" {visibleCharacters.map(character => (\n"
" <li key={character.name}>{character.name}</li>\n"
" ))}\n"
" </ul>\n"
" </div>\n"
" );\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.