$re = '/souly/m';
$str = 'import React, { useState } from \'react\';
const characters = [
{ name: \'Luke\', side: \'Jedi\' },
{ name: \'Vader\', side: \'Sith\' },
// Weitere Charaktere nach Bedarf hinzufügen
];
export default function ToggleCharacterView() {
const [view, setView] = useState(\'all\');
const [selectedSide, setSelectedSide] = useState(null);
// Wechsel zwischen "all" und "sides"
function handleToggleView() {
setView(view === \'all\' ? \'sides\' : \'all\');
setSelectedSide(null);
}
// Filter für Sichtbarkeit der Charaktere
const visibleCharacters =
view === \'all\'
? characters
: selectedSide
? characters.filter(c => c.side === selectedSide)
: characters;
return (
<div>
<button onClick={handleToggleView}>
{view === \'all\' ? \'Nur Seiten zeigen\' : \'Alle anzeigen\'}
</button>
{view === \'sides\' && (
<>
<button onClick={() => setSelectedSide(\'Jedi\')}>Jedi</button>
<button onClick={() => setSelectedSide(\'Sith\')}>Sith</button>
<button onClick={() => setSelectedSide(null)}>Zurücksetzen</button>
</>
)}
<ul>
{visibleCharacters.map(character => (
<li key={character.name}>{character.name}</li>
))}
</ul>
</div>
);
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);