using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( → .*)";
string substitution = @"";
string input = @"<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>
# A
# B
# C
# red → rouge
# yellow → jaune
# green → vert [pos:adjective, ipa: /vɜːt/]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}