import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( → .*)";
final String string = "<noinclude>sdfwrtg\n"
+ " {{draft}} \n"
+ "wertert\n"
+ "</noinclude>\n"
+ "# A\n"
+ "# B\n"
+ "# C \n"
+ "# red → rouge\n"
+ "# yellow → jaune\n"
+ "# green → vert [pos:adjective, ipa: /vɜːt/]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}