#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)rr\d---sn-[a-z0-9]{8}-\w{4}\.googlevideo\.com"
Local $sString = "rr9--- - -abcd.googlevideo.com" & @CRLF & _
"" & @CRLF & _
"rr1---sn-8xgn5uxa-quhl.googlevideo.com" & @CRLF & _
"rr1---sn-8xgn5uxa-quhl.googlevideo.com" & @CRLF & _
"rr3---sn-8xgn5uxa-quhz.googlevideo.com" & @CRLF & _
"rr6---sn-8xgn5uxa-quhl.googlevideo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")