package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rr\d---sn-[a-z0-9]{8}-\w{4}\.googlevideo\.com`)
var str = `rr9--- - -abcd.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr3---sn-8xgn5uxa-quhz.googlevideo.com
rr6---sn-8xgn5uxa-quhl.googlevideo.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}