const regex = /rr\d---sn-[a-z0-9]{8}-\w{4}\.googlevideo\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rr\\d---sn-[a-z0-9]{8}-\\w{4}\\.googlevideo\\.com', 'gm')
const str = `rr9--- - -abcd.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr3---sn-8xgn5uxa-quhz.googlevideo.com
rr6---sn-8xgn5uxa-quhl.googlevideo.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}