re = /rr\d---sn-[a-z0-9]{8}-\w{4}\.googlevideo\.com/m
str = 'rr9--- - -abcd.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr1---sn-8xgn5uxa-quhl.googlevideo.com
rr3---sn-8xgn5uxa-quhz.googlevideo.com
rr6---sn-8xgn5uxa-quhl.googlevideo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end