using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])$";
string input = @"192.168.9.1
256.122.122.122
255.122.122.122
0.0.0.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}