$re = '/^([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])$/m';
$str = '192.168.9.1
256.122.122.122
255.122.122.122
0.0.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);