const regex = /^([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])$', 'mg')
const str = `192.168.9.1
256.122.122.122
255.122.122.122
0.0.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}