re = /^([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])\.([0-1]?\d\d?|2[0-4]\d|25[0-5])$/m
str = '192.168.9.1
256.122.122.122
255.122.122.122
0.0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end