import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])\\.([0-1]?\\d\\d?|2[0-4]\\d|25[0-5])$";
final String string = "192.168.9.1\n"
+ "256.122.122.122\n"
+ "255.122.122.122\n"
+ "0.0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}