#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[A-Za-z0-9а-яА-Я\ ]+$"
Local $sString = "Пlkjlkasdf sdaf asd ads aфвав фщшрро ропоо ива йва ййй"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")