$re = '/^[A-Za-z0-9а-яА-Я\ ]+$/i';
$str = 'Пlkjlkasdf sdaf asd ads aфвав фщшрро ропоо ива йва ййй';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);