package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[A-Za-z0-9а-яА-Я\ ]+$`)
var str = `Пlkjlkasdf sdaf asd ads aфвав фщшрро ропоо ива йва ййй`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}