using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9а-яА-Я\ ]+$";
string input = @"Пlkjlkasdf sdaf asd ads aфвав фщшрро ропоо ива йва ййй";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}