const regex = new RegExp('^[A-Za-z0-9а-яА-Я\\ ]+$', 'i')
const str = `Пlkjlkasdf sdaf asd ads aфвав фщшрро ропоо ива йва ййй`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}