#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0\.[1-9]|[1-9]\.?\d?)$"
Local $sString = "01" & @CRLF & _
"0.0" & @CRLF & _
"1,1" & @CRLF & _
"2.75" & @CRLF & _
"27.5" & @CRLF & _
"999" & @CRLF & _
"ab" & @CRLF & _
"0.0" & @CRLF & _
"" & @CRLF & _
"Examples OK:" & @CRLF & _
"" & @CRLF & _
"0.1" & @CRLF & _
"0.1" & @CRLF & _
"1" & @CRLF & _
"5.5" & @CRLF & _
"10" & @CRLF & _
"99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")