use strict;
my $str = '01
0.0
1,1
2.75
27.5
999
ab
0.0
Examples OK:
0.1
0.1
1
5.5
10
99';
my $regex = qr/^(?:0\.[1-9]|[1-9]\.?\d?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}