$re = '/^(?:0\.[1-9]|[1-9]\.?\d?)$/m';
$str = '01
0.0
1,1
2.75
27.5
999
ab
0.0
Examples OK:
0.1
0.1
1
5.5
10
99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);