package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0\.[1-9]|[1-9]\.?\d?)$`)
var str = `01
0.0
1,1
2.75
27.5
999
ab
0.0
Examples OK:
0.1
0.1
1
5.5
10
99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}