import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\\s)?(?P<content>.*?)(?<!\\\\)(?=```)(?P<end>(?:\\\\\\\\)*```)";
final String string = "```php\n"
+ "$foo = 'Bar';\n"
+ "define('FOO', 'BAR');\n"
+ "```\n\n"
+ "```$foo = 'Bar';```Foobarbaz\n"
+ "Foobarbaz```$foo = 'Bar';```\n\n"
+ "/(?P<start>\\```)(?<=\\```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\```)(?P<end>\\```)/gs\n\n"
+ "(?<!\\\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=```php )(?P<end>(?:\\\\\\\\)*```)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}