re = /(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)/
str = '```php
$foo = \'Bar\';
define(\'FOO\', \'BAR\');
```
```$foo = \'Bar\';```Foobarbaz
Foobarbaz```$foo = \'Bar\';```
/(?P<start>\\```)(?<=\\```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\```)(?P<end>\\```)/gs
(?<!\\\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=```php )(?P<end>(?:\\\\\\\\)*```)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end