import re
regex = re.compile(r"(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)", flags=re.DOTALL)
test_str = ("```php\n"
"$foo = 'Bar';\n"
"define('FOO', 'BAR');\n"
"```\n\n"
"```$foo = 'Bar';```Foobarbaz\n"
"Foobarbaz```$foo = 'Bar';```\n\n"
"/(?P<start>\\```)(?<=\\```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\```)(?P<end>\\```)/gs\n\n"
"(?<!\\\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=```php )(?P<end>(?:\\\\\\\\)*```)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")